読者です 読者をやめる 読者になる 読者になる

久しぶりにpod installしたらエラー

rubyのバージョン変えてたので、まずはgemのインストール

gem install cocoapods
rbenv rehash

で、

pod install

すると、エラーが出てくる。 こんなの

Psych::SyntaxError - (/Users/〜〜〜/.cocoapods/repos/master/CocoaPods-version.yml): mapping values are not allowed in this context at line 3 column 4

ググったら、 https://github.com/CocoaPods/CocoaPods/issues/1853 こんなのが出てきたので、書いてあったコマンドを実行

rm -rf ~/.cocoapods/repos/master
pod setup

で、再度

pod install

すると正常に動いた模様。